You don't have Flash or HTML5 support– you should get one or the other.
Download Adobe Flash 10.0.0 or greater.

Click here to download it free: